Project

General

Profile

Defect #402

ScrollerPlus not working in 5.1.x

Added by Troy Elliott over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Start date:
12/26/2011
Due date:
% Done:

0%

Estimated time:
Browser (if web client):

Description

When putting the most recent version of ScrollerPlus into Servoy 5.1.4, the attached screenshot shows up in Developer and the plugins methods are not accessible when called from Debug Client. Reverting to version 1.0 fixes the problem, but this is not an option for deployment.


Files

scrollerplus_error.png (32.9 KB) scrollerplus_error.png Developer error tooltip Troy Elliott, 12/26/2011 09:50 PM

History

#1

Updated by Patrick Talbot over 9 years ago

  • Status changed from New to In Progress

Must be due to changes in Servoy's public API. Could you attach the Exception that must be in your servoy_log.txt?

#2

Updated by Troy Elliott over 9 years ago

I actually don't see anything in servoy_log.txt when I get this error. Any other place where I can check?

#3

Updated by Patrick Talbot over 9 years ago

No, I found it. But the problem is that there are lots of method calls here that relies on 5.2...
5.1.x have most of the objects I'm calling obfuscated, so I'm not actually sure I will be able to make it work in 5.1...
I'll have a look next week.

#4

Updated by Patrick Talbot over 9 years ago

  • Status changed from In Progress to Resolved

OK, the downloadable version was the wrong one, without the refactoring I did to make it work with Servoy 5.1 using Reflection on obfuscated methods.
I've uploaded a (signed) jar which should be the one to use with Servoy v1.5.4

Also available in: Atom PDF